Supported Browsers

 Staff View works on any modern desktop browser.

  • Microsoft® Internet Explorer® versions 9, 10, and 11

    Internet Explorer versions 9, 10, and 11 are not supported for Lightning Experience or autocomplete for labels and inline creation / editing of field sets in the Community Hub Setup App 

  • Microsoft® Edge®, most recent stable version

  • Mozilla® Firefox®, most recent stable version

  • Google Chrome™, most recent stable version

  • Apple® Safari® on Mac OS X, most recent stable version

Community Hub works on any screen size on any device and supports all modern browsers.

  • Microsoft® Internet Explorer® versions 9, 10, and 11

  • Microsoft® Edge®, most recent stable version

  • Mozilla® Firefox®, most recent stable version

  • Google Chrome™, most recent stable version

  • Apple® Safari® on Mac OS X and iOS, most recent stable version

For all browsers, you must enable JavaScript, cookies, and TLS 1.1 and/or TLS 1.2 enabled.

In This Section